ies4osx 2.99.0.1-4

May 30th, 2008 by

This one was due for some time!

But I simply was not finding a showstopping bug, when run outside XCode.
So for the afterworld: If you happen to pipe output from a script started with NSTask, “ps” will act as “ps A” if run inside XCode and as “ps” if run in liberty (i.e. You’ll see all processes in XCode, but not if released).

What’s new?

  • New launcher for Internet Explorer. Much lighter and it will terminate all instances of wine and wineserver (read all Windows Programs) before lauching a new copy of Internet Explorer. This is mainly to get rid of hanging internet Explorers.
  • Error checking and progressmeter for downloads. This is a try to prevent incomplete installations. Unfortunately, the MS server for the ActiveX controls will still turn you down, half of the times, but at least you know it, now.

Best run with a new copy of Darwine-1.0rc2! 😉

You find ies4osx here:
www.kronenberg.org/ies4osx

Mike

Tags:

12 Responses to “ies4osx 2.99.0.1-4”

  1. I think this is the reason it doesn’t work for me since 2_5. But Darwine works very good. Thank you.

    # Installing IE 6
    Initializing
    Creating Wine Prefix
    Extracting CAB files
    Installing IE 6
    mv: rename cscript.exe to /Users/ooscarr/Applications/IEs 4 Mac/.ies4mac/ie6/drive_c/windows/Command/: No such file or directory
    Installing DCOM98
    mv: rename /Users/ooscarr/Applications/IEs 4 Mac/.ies4mac/ie6/drive_c/windows/system/dcom98.inf to /Users/ooscarr/Applications/IEs 4 Mac/.ies4mac/ie6/drive_c/windows/Inf/: No such file or directory
    Installing TTF Fonts
    usage: mv [-f | -i | -n] [-v] source target
    mv [-f | -i | -n] [-v] source … directory
    Installing Core Fonts
    usage: mv [-f | -i | -n] [-v] source target
    mv [-f | -i | -n] [-v] source … directory
    Installing ActiveX MFC42
    mv: rename mfc42.inf to /Users/ooscarr/Applications/IEs 4 Mac/.ies4mac/ie6/drive_c/windows/Inf/: No such file or directory
    Installing RICHED20
    Installing registry
    Finalizing
    [ OK ]

    # Creating .App packages
    Internet Explorer 6.0
    sed: /Users/ooscarr/Desktop/Internet Explorer 6.0.app/Contents/Resources/start.sh: No such file or directory
    [ OK ]

    # IEs4Mac installations finished!

    Comment by Oscar — May 30, 2008 @ 13:15

  2. Was this with 2.99.0.1-4 from today?
    If yes, did it stop, when downloading failed?
    I sometimes have to try up to 4 times to get a proper download.

    Mike

    Comment by mike — May 30, 2008 @ 13:35

  3. I browsed (I’m sorry for my bad English) the Internet Explorer 6.0.app package and I found Spanish Windows folders like ie6/drive_c/windows/profiles/ooscarr/Escritorio (and Favoritos, Configuración local, Menú Inicio, Mi música, Mis documentos, Mis imágenes, Mis videos) and I thought: maybe it is because my Mac OS X Leopard is in Spanish! So I went to System Preferences (Preferencias del sistema) and changed the Mac OS X languaje to English. I moved Internet Explorer 6.0.app to the trash, I run ies4osx again, installed Internet Explorer 6 again and now it works. I’m very happy now. (I tested with the English(US) and Español IE6 versions, now they both work).

    Now that Internet Explorer is working, I returned the system language again, and now that it is correctly installed, it works with my system in Spanish again.

    During installation of ies4osx, Mac OS X must be in English is what I want to say.

    Comment by Oscar — May 30, 2008 @ 16:35

  4. Oscar,

    txs for the hint, I might turn automatics search for language off.

    Mike

    Comment by mike — May 30, 2008 @ 17:03

  5. Hi Mike,

    How does it look on solving the 100% of my cpu issue?

    Comment by Bay — May 31, 2008 @ 12:47

  6. It seems like sometimes there is one proces left after closing IE and X11 – wineserver – that usues nearly 100% CPU (after couple of minutes my mini starts blowing and than i know that I must kill this process)

    but sometnimes after closing IE everything works just fine

    Comment by Roberto — June 3, 2008 @ 17:47

  7. Hello Mike,

    Thanks for good work with darwine and ies4osx.
    I have a problem, ies4osx won’t download any files! Have tried over and over again, and get this error in the log everytime:
    —–
    # Downloading everything we need
    Downloading from microsoft.com:
    DCOM98.EXE
    ps: option requires an argument — p
    usage: ps [-aACcehjlmMrSTuvwx] [-O|o fmt] [-p pid] [-t tty] [-U user]
    ps [-L]
    mfc42.cab
    ps: option requires an argument — p
    usage: ps [-aACcehjlmMrSTuvwx] [-O|o fmt] [-p pid] [-t tty] [-U user]
    ps [-L]
    249973USA8.exe
    ps: option requires an argument — p
    usage: ps [-aACcehjlmMrSTuvwx] [-O|o fmt] [-p pid] [-t tty] [-U user]
    ps [-L]
    ..etc..
    # Installing IE 6
    Initializing
    Creating Wine Prefix
    Extracting CAB files
    /Users/username/Applications/IEs 4 Mac/.ies4mac/downloads/ie6/EN-US/ADVAUTH.CAB: No such file or directory
    ..etc..
    —–
    Mac OS X 10.4.11 – X11 1.1.3 – XFree86 4.4.0 – Intel Core 2 Duo

    Comment by Vemund Hagen — July 1, 2008 @ 11:00

  8. Hello,
    Thanks for your work but I got the same errors than Vemund Hagen :

    # Installing IE 6
    Initializing
    Creating Wine Prefix
    Extracting CAB files
    /Users/simon/Applications/IEs 4 Mac/.ies4mac/downloads/ie6/EN-US/ADVAUTH.CAB: No such file or directory
    /Users/simon/Applications/IEs 4 Mac/.ies4mac/downloads/ie6/EN-US/CRLUPD.CAB: No such file or directory
    /Users/simon/Applications/IEs 4 Mac/.ies4mac/downloads/ie6/EN-US/HHUPD.CAB: No such file or directory
    /Users/simon/Applications/IEs 4 Mac/.ies4mac/downloads/ie6/EN-US/IEDOM.CAB: No such file or directory
    /Users/simon/Applications/IEs 4 Mac/.ies4mac/downloads/ie6/EN-US/IE_EXTRA.CAB: No such file or directory
    /Users/simon/Applications/IEs 4 Mac/.ies4mac/downloads/ie6/EN-US/IE_S*.CAB: No such file or directory
    /Users/simon/Applications/IEs 4 Mac/.ies4mac/downloads/ie6/EN-US/SETUPW95.CAB: No such file or directory
    /Users/simon/Applications/IEs 4 Mac/.ies4mac/downloads/ie6/EN-US/VGX.CAB: No such file or directory
    !! An error occured when trying to cabextract some files.

    Would you have any idea how to fix this ?

    Thanks, Simon

    Comment by Simon — July 12, 2008 @ 11:15

  9. I have tried with both the “stable” and “unstable” darwines and have the problem: Running ies4osX with the default options always hangs at the “Creating Wind Prefix” step.

    Comment by Jamie Hoover — July 24, 2008 @ 18:22

  10. I solved the “Creating Wine Prefix” hanging problem by installing XQuartz: http://xquartz.macosforge.org/trac/wiki/X112.2.3

    F.Y.I.: the more recent version of XQuarz, 2.3.0 was not compatible with my Wacom Tablet.

    Comment by Jamie Hoover — July 24, 2008 @ 19:30

  11. I upgraded to 10.5.4 from 10.4. Before upgrade IE6 was installed with ies4osx. I used flashplayer and Authorware Player with no problem. After upgrade had to install X11 from Xquartz as I could not launch X11 installed from Leopard disk. Now I have no sound at all from any site. I installed latest DarWine. Reinstalled IE6 and flashplayer and authorware player. I’ve checked internet settings from IE6 and audio is checked. I’ve checked DarWine config and AUDIO has driver checked and “test sound” works. Don’t know what else to check.

    Comment by EAS — August 3, 2008 @ 00:38

  12. Still no answer on the: An error occured when trying to cabextract some files. Somebody knows the answer and I’ll send him some real wine!!

    Comment by marc — August 7, 2008 @ 15:11